[Workaround] V-ray 3.6 does not show skatter objects.



**SketchUp version :2017
Skatter version (Skatter dialog > Options > About) : 1.4.2
**OS :windows 7
**Description of the issue :vray 3.6 does not render skatter
Are you able to reproduce the issue every time? (If yes, how?) : yes, by making a new skatter object. They do not show up in the vray asset geometry tab. Old sketchup files with already made skatter objects render fine in the new vray.
Error in Ruby Console? (Window > Ruby Console) : -


Weird, I can’t reproduce this issue.

Does this happen when you scatter a simple cube?


Same problem here. MacOS High Sierra SU 2017 Pro. Tried an old scene, no luck. New scene also no luck. Skatter version 1.4.2. I tried a simple scatter with a cube as you suggested but nothing…



Hi Thomas, yes it does happen with a simple cube as well.
I found out it does not happen when I make the cube a vrmesh first and then scatter the proxy.


Hey, I am having the same issues. Nothing appears on the v-ray geometry list, this happens in both new and old sketchup files. I have also noticed that the preset skatter libraries do work and appear in the v-ray geometry list. I have also tried simple cubes with no luck.

OSX 10.11.1
Sketchup Pro 2015
Ray 3.6
Skatter 1.4.2


**SketchUp version :2017
**Skatter version: 1.4.2
**V-Ray: 3.6
**OS: Windows 7
**Description of the issue: vray 3.6 does not render skatter except grass!

I am also having this problem! As you can see in the screenshot, objects are in the geoemtry list but they don’t get rendered!
If I also add trees (NOT in this screenshot), all the textures are lost but they appear in the Material list and they are assigned properly!

Any solutions so far?!



It seems 3.6 breaks compatibility with Skatter. We will address this in 3.60.02. As a temporary workaround, open the ruby console and copy and paste the following one liner

class VRay::LiveScene::Mesh;def material;get_material(nil);end;end

This has to be done once for each SketchUp session
Sorry for the inconvenience

Render of two components into the same scene
Invisible plant with render only
[release] 1.4.4


Seemingly, this work around only works for one skatter (as in it works for rocks if I do that first, but then if I do trees - nothing). Any clue on when the update will be pushed?


Nevermind, I just have to reset the vray render.


Skatter now automates the workaround in version 1.4.4 : [release] 1.4.4


This has been properly fixed in V-Ray 3.60.02 : https://docs.chaosgroup.com/display/VRAYSKETCHUP/3.60.02

Update to V-Ray 3.60.02 now!