Mother of all Bugs (MOAB)


#1

SketchUp version : 2016
Skatter version (Skatter dialog > Options > About) : 1.4.2
OS : Win 7 Ultimate SP 1
Description of the issue : Sketchup hangs on Start up
Are you able to reproduce the issue every time? (If yes, how?) : Yes, below
Error in Ruby Console? (Window > Ruby Console) : Wouldn’t know.

I have encountered a major problem that crashes Sketchup on start up everytime. Here’s how ->

  1. Create a new file with dimensions in meters.
  2. Pick any skatters from the library and skatter the proxies only on a surface (even a 1x1m square). From Skatter’s render list, uncheck the newly created skatter (which should be the only skatter anyway).
  3. Save and close the file.
  4. Open above file, change dimensions to millimeters, then save+close
  5. Open the file. Sketchup hangs and subsequently the computer, solution being a hard reset.

The above procedure is just for replicating the bug. I encountered it while working on a major file. I had to lose data after the hang.

Now, the only solution I have so far is disabling skatter from the extensions menu and moving the content to a new file.

I imagine the error is as a result of unit conversion, and would like to request for a way to clear skatter data from a Sketchup file.

Regards,

Szczalo


#2

This is a known issue. For now the only solution is to either change the model unit back to the original, or change the values in the Skatter setup before changing the model units.

We will try to have this fixed for V2.