Skatter Library does't load



I have a problem to load a grass or any other object group prom Skatter library. Any thoughts why is it so?

Thank you


What happens exactly? Any error popup?


No, no errors popn up. Only thing that when I choose from skatter library and press load, nothing happens and does not turn into the option where I need to select my surface as an object. In one of the files, where I could do that , whenever I try a new load then it works but in a new sketchup file when I try to load trees or bushes it does not…


Try this :

  • Open a new Sketchup file
  • Open the Ruby Console (Window > Ruby Console) and keep it opened
  • Open the Skatter library and try to load a preset
  • Tell me what appears in the ruby console


DL is deprecated, please use Fiddle

---- Skatter 1.3.0----
Regenerate render instances from attributes : 0.0 s
---- End ----

Skatter overwrote Vray’s ‘write_to_xml’
Error: #<NoMethodError: undefined method instances' for nil:NilClass> C:/ProgramData/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/library.rb:208:inblock (2 levels) in start_lib_dialog’
C:/ProgramData/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/library.rb:185:in each' C:/ProgramData/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/library.rb:185:inblock in start_lib_dialog’
C:/ProgramData/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/dialog.rb:20:in call' C:/ProgramData/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/dialog.rb:20:inblock in add_bridge_callback’
SketchUp:1:in `call’


This is very strange.
There’s nothing after “Error: #” ? (Before “C:/ProgramData/...”)



Do you see .skp files in C:\ProgramData\Skatter\Library ?


Yes, I can see all the files…


Could that be a problem? I have tried to open those files in sketchup and some of them are created in later version…


Only proxy files are created in a later version, full 3d model of trees or bushes ar ok to open


Oh yes indeed, that’s more than likely the problem!
Those files are supposed to be version 2014 of Sketchup, I’ll fix this for the upcoming version (should be out in a few days)


Perfect! But do I need to reinstal skatter when you fix it?


Yes you will need to install the new version.


Thank you very much!


Can you confirm that it only happens with the Bushes preset, when loading as Proxies?

That’s the only one I have been able to reproduce the issue with.


I could not load everything except all the grass in sketchup skatter library. But I could not open bushes proxy sketchup file from C:\ProgramData|…