[Workaround] V-ray 3.6 does not show skatter objects.


#1

WORKAROUND/FIX : Click here

**SketchUp version :2017
Skatter version (Skatter dialog > Options > About) : 1.4.2
**OS :windows 7
**Description of the issue :vray 3.6 does not render skatter
Are you able to reproduce the issue every time? (If yes, how?) : yes, by making a new skatter object. They do not show up in the vray asset geometry tab. Old sketchup files with already made skatter objects render fine in the new vray.
Error in Ruby Console? (Window > Ruby Console) : -


#2

Weird, I can’t reproduce this issue.

Does this happen when you scatter a simple cube?


#3

Same problem here. MacOS High Sierra SU 2017 Pro. Tried an old scene, no luck. New scene also no luck. Skatter version 1.4.2. I tried a simple scatter with a cube as you suggested but nothing…

Best,
Peter


#4

Hi Thomas, yes it does happen with a simple cube as well.
I found out it does not happen when I make the cube a vrmesh first and then scatter the proxy.


#5

Hey, I am having the same issues. Nothing appears on the v-ray geometry list, this happens in both new and old sketchup files. I have also noticed that the preset skatter libraries do work and appear in the v-ray geometry list. I have also tried simple cubes with no luck.

OSX 10.11.1
Sketchup Pro 2015
Ray 3.6
Skatter 1.4.2


#6

**SketchUp version :2017
**Skatter version: 1.4.2
**V-Ray: 3.6
**OS: Windows 7
**Description of the issue: vray 3.6 does not render skatter except grass!

Hey,
I am also having this problem! As you can see in the screenshot, objects are in the geoemtry list but they don’t get rendered!
If I also add trees (NOT in this screenshot), all the textures are lost but they appear in the Material list and they are assigned properly!

Any solutions so far?!

cheers
SLesch


#7

It seems 3.6 breaks compatibility with Skatter. We will address this in 3.60.02. As a temporary workaround, open the ruby console and copy and paste the following one liner

class VRay::LiveScene::Mesh;def material;get_material(nil);end;end

This has to be done once for each SketchUp session
Sorry for the inconvenience


Render of two components into the same scene
Invisible plant with render only
[release] 1.4.4
#8

#9

Seemingly, this work around only works for one skatter (as in it works for rocks if I do that first, but then if I do trees - nothing). Any clue on when the update will be pushed?


#10

Nevermind, I just have to reset the vray render.


#11

Skatter now automates the workaround in version 1.4.4 : [release] 1.4.4


#12

This has been properly fixed in V-Ray 3.60.02 : https://docs.chaosgroup.com/display/VRAYSKETCHUP/3.60.02


Update to V-Ray 3.60.02 now!
#13

I am using the latest version of vray…and the latest version of skatter…Please see below for an infuriating issue I am having. Please note: I did a comparison to see if things were just user error and used default settings for vray 3.6 (on medium quality), and vray 2.0

The issue I am having is hurting my business soo soo bad in the last 4 days as I needed to switch over to vray 3.6…Once I did all hell broke loose…it seems to all stem around Laubwerk, Skatter (or vray), and the switch to a new material set up with a linear process.

I fixed the laubwerk issue by upgrading. Then i found this thread and upgraded skatter…I am still having huge issues and here is what they are.

Skatter objects will show in the vray 3.6 panel & they will also show proxy previews…I can also render the grass in realtime when its JUST THE SKATTER GRASS ONLY. When I turn on the whole model , or do a final render, one of two things happen. 1) the rendering never even gets to the initial light distribution phase, OR 2) it starts rendering…gets about 3 hours in and crashes during the rendering phase. I have tried this multiple times now…When I render with out any skatter objects vray renders fine so I know its some sort of interface with either skatter geometry or skatter materials!

I got so frustrated that I decided to uninstall vray 3.6 for sk up 2017, and reinstall vray 2.0 for use on skup 2015. I used the same scene and not only did it do the full render it was FAST AS SHITT!..like at least 4 to 5 times faster ( please see above for my description of my vray settings).

Now, all things being equal, chaos group is swearing up and down that using their default settings for vray 3.6 is the best thing to do as it is already optimized so the issues should in no way be with my settings in Vray 3.6.

MY QUESTION IS, DOES VRAY USE RAM LIKE A TOTAL ASSHOLE NOW OR IS THERE STILL A PROBLEM WITH SKATTER INITIALIZING? COULD IT BE IMPROPER PORTING OF MATERIALS FROM SKATTER’S OBJECTS INTO VRY 3.6?. COULD IT BE A GEOMETRY INITIATION ISSUE? Remember…it worked AMAZINGLY on vray 2.0 for SkUp 2.0.

One thing to note…when I opened my down saved model from skup 2017, which had optimized materials for vray 3.6, and opened it in skup 2015 for vray 2.0 I noticed all of my textures had either gone wonkey or were rendering weird or freezing vray 2.0… As a result I re -extured everything for vray 2.0 and DELETED THE SKATTER ELEMENTS, PURGED THE MODEL AND REAPPLIED SKATTER AGAIN IN 2015/ VRAY 2.0…

Do you have any thoughts on weather or not vray decided to get ass crazy with ram or is this still an issue with skatter…Skatter is amazing but I literally can not use it or rely on it for 3.6 now!..I am probably going to have to resort to getting good with vray fur, which I dont want to do!..

I literally so tired from staying up the last 3 days now trying to figure all this out

AHHHHHHHHHHGHGHGHG.

Also, Please pleas please, allow skatter to skatter inside of a watertight volume!..I.e. I make a sphere and then I can skatter inside the volume using the boundaries of the surface as the skatter bounds…That would be amazing!!!

Love you


#14

Hi,

It really does sound like a RAM issue. How much RAM do you have installed in your machine?


#15

I would seem as though that is an irrelevant question as it rendered totally fine in vray 2.0…just not 3.6.02…sooooooooo what is going on? There are obviously two plugins in a play here and it is well documented that there were a number of issues with both of your plug ins playing with each other when vray upgraded.


#17

Indeed there’s been some issues in V-Ray 3.6 regarding parsing Skatter data, but what I’ve seen so far has been resolved by Chaos Group.
What you are describing is different from everything else in this forum thread.

The fact that Skatter grass renders fine until you unhide the rest of the model, makes me think it is not an issue related to Skatter directly, but instead V-Ray not being able to handle all of this data (Skatter + model). In my opinion, it is probably related to RAM, this is why I’m asking how much you have installed in your machine.
Also, open the Windows Task Manager before rendering, and check if RAM usage approaches 100%.