Skatter Freezing Sketchup


#1

I used skatter to create a bunch of the grass from skatter library. Everything was working great until I saved the file and re-opened it. Now I basically can’t use my file anymore. When I open the file the entire thing freezes. I figured out that if I disable the skatter plugin the file works fine, but I like skatter and want to use it. Any suggestions?


#2

Could you send me the file to [email protected] ?


#3

Thanks for the file.
Skatter is not actually freezing Sketchup. You have a lot of Skatter setups, some of them are taking a long time to compute. At Sketchup startup, Skatter re-computes every setup (otherwise if everything was stored in the file, the file would be huge), that’s why it takes a long time to open your file (5 minutes on my computer).

The more geometry (faces, edges) in your surfaces/curves, the more time it takes to compute.
And obviously, the more objects scattered, the more time it takes to compute.

There is no way around it for now.
I will try to optimize this by not computing at startup the “disabled” setups.


#4

Is it possible when opening a file to have the warning with an abort option when skatter compute is taking more than x seconds ?

I had a file where I had to disable skatter before opening it and delete the host before re-activating skatter to make it work …


#5

I will add this to my todo list.