Removal of "Trace Reflections" in V-ray materials grass proxies


#1

Note: The scene was created, rendered and posted without post processing using the default vray options with the “Raw reflection” and “Specular” passes enabled under VFB channels.

Hello,

After using vray on sketchup for a while, I discovered that “trace reflections” option under V-ray material editor - Options adversely affects render time. As a solution, for materials that I’d rather show the specularity only, like grasses and trees, I normally turn this off.

With trace reflections ON : Took 33 minutes
https://drive.google.com/file/d/0B3XXDAl-vV8FbW40MTlsclBYUjA/view?usp=sharing
https://drive.google.com/file/d/0B3XXDAl-vV8FaDg2MnNTT2lqWkU/view?usp=sharing
https://drive.google.com/file/d/0B3XXDAl-vV8FeEY2Y1p1WDFrUkU/view?usp=sharing

With trace reflections OFF : Took 16 minutes
https://drive.google.com/file/d/0B3XXDAl-vV8FRmxlelQyOVJObkE/view?usp=sharing
https://drive.google.com/file/d/0B3XXDAl-vV8FWXh3NTlGNDRoRzA/view?usp=sharing
https://drive.google.com/file/d/0B3XXDAl-vV8FdEpGYXFiVEUtQmM/view?usp=sharing

By default, the skatter grass bundles have this option turned on (https://drive.google.com/open?id=0B3XXDAl-vV8FbDRYeWFnOGRZVWc) and every time I open a scene on sketchup, I have to turn it off. Every time. Somehow, once the proxies are reloaded, the option is always on. I have tried a local solution, that is, editing the grass from the library, first the actual SU model, then saving it as a proxy to replace the original but it seems to stop vray from rendering the particular grass.

I would thus propose that we have the bundled grasses have this option turned off by default, or even an option on the skatter dialog that turns it off or on as per user preference.

NB, with trace reflections I contend that the grass does look better, but with a little photoshop using the specular channel, the no-trace reflections grass looks stunning too :smiley: IMHO. The question is, are I willing to take twice the time to produce the grassy bits? Nope! P.S. It took me an hour+ to do this…and here is the no-trace reflections image after applying the specular channel on photoshop (Screen blend mode only) - https://drive.google.com/file/d/0B3XXDAl-vV8FQVBCdG1hTXVCVHM/view?usp=sharing


#2

I didn’t know about that option, thanks for pointing it out.
I’m not sure that I want to disable it by default, but I will look into the feasibility of a checkbox in the Skatter options.

Meanwhile, you can do this:

  • Load the grass preset you want
  • Disable Trace Reflections in all 3 materials
  • Rename the materials from Vray’s material editor (very important)
  • Rename the component definitions (“skatter_medium_grass_01_large_proxy_custom” for instance)
  • Save the Skatter setup in the library with the name you want

You now have a setup identical to the default one, but with your custom materials, and you made sure they have different names so they are not overridden.


#3

Thanks for this, I will go through the grasses and make my custom.