Long wait after opening complicated skatter sketchup file


#1

Hi Thomas!

Finally getting my finished renders out on my favourite scene (many mentions before!)… its got many areas of skatter grass (and border edge versions) - all manageable…

However, does Skatter have to calculate everything on first open of the file ? I now have to wait approx 30 mins on opening the file - I don’t need any new recalculations as all is set as required - I’m just rendering scenes with Thea… so do the generated Skatter setups get saved with the file or are they new every time?

Thanks,

Phil


#2

Hi Phil,

Skatter saves in the file only the settings of your setups. The actual data is generated each time you reopen your file, then stored in RAM waiting for the render engines to read it.
The reason it’s done this way is because when you reach thousands of generated objects, the data can take A LOT of space. You can see it in your RAM usage, it can reach several gigabytes. Saving this in the file would mean that your file would get really really huge.

In very early alpha versions it was actually done this way, but I quickly changed it.


#3

Thanks Thomas. Good to know!


#4

Is there a way to not generate the data each time the model is opened?
I’ve had the issue of working on the model, adding skattered objects, then having to carry out further editing while the PC/SketchUP is creaking.
My current workaround is to disable Skatter, restart SketchUP, then open the model for further editing.


#5

You can disable the Skatter setups in the Render List (untick the checkboxes), then go to the Options tab and tick “Do not compute disabled setups at startup”.


#6

OK, thanks.