Skatter grass on a sandbox modeled terrain


Greetings everyone,

First post here, so sorry for any newbiness. =)

I’ve modeled a terrain using sketchup’s sandbox (attached print screen), and then applied the skatter’s library grass (medium size I guess). The thing is that the rendered grass (via vray) is not coming up as it should be. I have in the past rendered flat surfaces, including on this particular model, and it works just fine.

So I conclude that it must be something with the sandboxed terrain (probably the fact that the triangulation of the terrain is pointing the faces to different places). Is there any way to get a good result in this kind of situations ?

Thank you very much in advance.


You sure thats grass?? Looks more like small bushes
Perhaps cause your terrain is made of triangles and not quads, doesnt look that smooth. But it seems the models are scaled weird.

Did you check the scaling numbers, perhaps they are to big


I did a quick test using a different renderer. I most say, i also see the lines when i look carefully. This plane is 250m long and i procuced 6.2mil grass objects :slight_smile:

If you look closely on the left side you see sort rows of grass. I havent set the smoothing on the grass floor, perhaps this helps.


Ive tried various settings, but it doesnt seem to go away.

Perhaps bob can enlighten us :slight_smile:


Thank you so much for taking your time ! =)

I’m using the existing “Medium Grass” from Skatter’s library and not changing any settings at all.

The thing is with a flat surface it works pretty well, but in a modeled terrain it happens as you see in the images… I’m still getting used to Skatter so most likely I’m missing something here.

I also made a new document with a quick sandboxed terrain and applied grass to it. Same thing happens… I’m sharing the definitions I have on Skatter just in case I’m skipping something !!


PS i think you have to big number for the X- and Y-rotation. leave it low or else you’ll see grass patches on its side. It think thats what we’re seeing in your imaeg


When i look at your image, the grass is rotated at a certain axis. Thats weird cause i dont see that with my models. Im using thearender though. Perhaps you should check the models, i think there is a error in there.

But the i noticed that using a big non flat surface makes lines in the skatter. I report this as a bug


Hi rombout ! Sorry for the late reply…

I changed the “X” and “Y” rotation values as you suggested and improved significantly the result…

Thanks a lot for taking your time with this :wink:


Great bro! I filled a report for the issue i noticed when large sandbox areas are use. I hope they can come up with something.


Hi Fabio,
For some reason, I noticed that sometimes the surfaces generated by the Sandbox tool have very weird normals. I don’t know why, and I don’t think I can do anything about it from Skatter.
As the grass presets are configured to have the pointing direction halfway between the up axis and the surface normal, your components end up rotated sideways.
The workaround I found is to explode the group generated by Sandbox, then group the geometry again, and then start Skattering.

Either way, please send me the file so I can take a look at it :

Rombout, you are seeing a different issue, I replied to you in your own thread.


Hi Thomas,
Thank you very much for the input… I will give it a try and let you know.
Currently it’s happening in every terrain I model, but I can def make another one and send it to you… :wink:


That would be great :slight_smile:


Does skattet put more models near such dents or bulges? It’s as if they are not placed over those lines


No it does not :slight_smile:


Well I’m wondering why such a small angle is visible than. If objects are shattered over this edge why is it ten clearly visible?


Because the objects are very small compared to the size of the faces. With bigger objects it wouldn’t be as visible.
The angle may be small, it still exists. And it’s especially visible when the light is almost parallel to the faces.