Creating Custom Skatter Objects


Hi Everyone,

Sorry if this is a dumb question but I need help creating custom Skatter Objects. I downloaded these SketchUp grass models and followed this tutorial to make the objects but I can’t apply the objects to any area larger than about 400 square feet or else it takes forever to generate (never really finishes). I also read over Ronen Bekerman’s tutorial but noticed he really only covers the modeling and materials side and a few Skatter settings.

My question is…am I supposed to make the model into a proxy first? I haven’t found anywhere where it clearly says to (unless I just haven’t found it). Is there a recommended procedure to follow when creating your own Skatter objects (specifically grass and other ground cover)?

Also in my tests of Skattering the above mentioned grass model I was never able to get the Skatter pattern to come out as square as the one in the tutorial. Is that to do with the shape of the Skatter object or something else I’m missing? I know to get the hard edge you have to have 2 different Skatter layers (one for the center and one for the edge) but they never mentioned that in the tutorial. Are there any recommendations for Center Skatter Objects vs Edge Skatter objects? Sorry for the lengthy post and sorry if this question has been asked before but I looked all over and cannot find anything on these subjects. Any advice would be much appreciated. Thanks in advance.


The issue with this tutorial is that it advises to use Collisions to control the density. You should NOT do that. Collisions are not meant for that. This setting can make Skatter really slow very quickly once it starts to deal with large numbers of objects (it computes the distance between each object with every other object).
To control the density while avoiding holes and clusters, use the “Uniform” distribution type :

What you can do is load a Grass preset from the library, delete the Scattered Objects from the list and pick your own. That way you can see the settings I used to create these grass presets.

If you use “Render only”, using proxies or not won’t matter. But the original object definition is still stored in the model, so if you have a tree composed of 2 millions polygon, it will increase the file size (and slow down Sketchup at startup) and you should probably make it a proxy. But a small grass patch shouldn’t be an issue.

You are probably looking for the Boundary Check setting :
Set it as “Size”.


Wow! Thanks a bunch. This helps a lot.